April 2015


Real LifeSonstigesMartin Richter - Fr 24 Apr 2015 20:18

Es war mal wieder soweit und ich musste bei Adobe (eigentlich keine kleine Firma) ein Update bestellen.
Dank Firmenkreditkarte war das kein Problem. Und so fing das Leid an:

20.03.2015 –
Ich bestelle ein Update eines typischen Adobe-Tools. Ich gehe den Bestellvorgang durch und schwupps ist der Kauf getätigt.
Alles super. Aber ach… 🙁 ein paar Stunden später kommt die Rechnung und die stimmt nicht. Ich denke ich kaufe bei Adobe-Deutschland, aber dem war nicht so. Ich bekomme das Produkt aus Irland und scheinbar war in meinem Adobe Konto keine Umsatzsteuer ID enthalten. 😳 Mea culpa, mea maxima culpa…
Ich geistere durch mein Konto bei Adobe, kann aber die verfluchte Stelle nicht finden wo die Umsatzsteuer ID einzutragen ist.
Ein Anruf bei der Hotline ergab, dass ich am Besten die Bestellung storniere. Bei der Gelegenheit hat der gute Mann an der Hotline auch die gültige Umsatzsteuer Id eingetragen.

23.03.2015-
Ich habe nun Aufgrund der Empfehlung der Hotline die Bestellung storniert. Natürlich ist die Kreditkarte schon belastet. Nochmal bei der Hotline angerufen und wirklich geklärt, dass eine Umsatzsteuer ID eingetragen ist.
Jetzt wurde eine neue Bestellung aufgegeben. Betrag stimmt schon mal in der Anzeige, aber das hatten wir schon.
Ein paar Stunden später die Überraschung. 😯 Die Rechnung weist die Mehrwertsteuer schon wieder aus, unsere Umsatzsteuer ID steht nicht auf der Rechnung. Wie kann das sein? Und noch besser: Eigentlich ist die Umsatzsteuer in Irland 21%. Die Rechnung zeigt aber 19% Mehrwertsteuer… jetzt ist es aber ganz wild.
Anruf bei der Hotline. Der kann sich das nicht erklären. Die Bestellung ist richtig. Die Umsatzsteuer ID ist eingetragen! Und noch besser: die Kreditkarte wurde nur mit dem Betrag ohne Mehrwertsteuer belastet. Gibt es so was?
Die Fakten in kürze: Rechnung falsch mit deutscher Mehrwertsteuer, Rechnung kommt aus Irland und trotz angegebener Umsatzsteuer ID steht da eine MwSt. Aber bezahlt habe ich die nicht… Ich werde vertröstet. Der Vorgang liegt nun bei der Fachabteilung.

27.03.2015 –
Die Stornierung der ersten Bestellung wurde akzeptiert. Wenigstens schon mal was 😉

29.03.2015 –
Wow. Nach 9 Tagen habe ich wenigstens das Geld für die erste Bestellung zurück.

05.04.2015 –
Meine Buchhaltung wird sauer und möchte eine Rechnung haben. Ich gebe den Vorgang soweit ich ihn habe inkl. falscher Rechnungen weiter.

18.04.2015 –
JAAAA! Eine Reaktion. Ich bekomme eine Email. Betreff meine Bestellung. Anhang: Eine PDF mit mir bereits bekannten FALSCHEN Rechnung. Auch hier 19% Steuer (statt irländischer 21%), die aber wegen Angabe der Umsatzsteuer ID nicht da stehen dürfte… 😡
Kein Text, keine Signatur nichts! Eigentlich eine Frechheit.
Kommt jetzt auch noch eine Kartennachberechnung… oder was? 🙁

23.04.2015 –
Die Buchhaltung setzt sich mit Adobe wieder in Verbindung. Der Man von der Hotline ist wieder nett und sieht den ganzen Vorgang. Er kann aber nichts machen.
Kurze Zeit später erhalte ich wieder eine Bestätigung, dass mein Vorgang an die entsprechende Fachabteilung weitergereicht wurde. Hatten wir das nicht schon vor 1 Monat.

Mittlerweile Frage ich mich, an wen man sich eigentlich wenden kann, wenn eine Firma eine definitiv falsche Rechnung ausstellt. Laut Auskunft meiner Buchhaltung müsste man ja diesen Betrag verbuchen, denn die Rechnung weißt diesen ja aus. Aber abgebucht wurde ein anderer Betrag. Also haben wir nun Schwarzgeld in der Kasse? 🙂 OK ich bin kein Buchhalter und das ist gut so…

Mein Urteil über Adobe? Am Besten fragt mich keiner…

23.05.2015 – DAS ENDE!
Nach nochmaliger Nachfrage bekam ich eine Email mit einer korrekten Rechnung. Kein Text keine Anrede, keine Entschuldigung.Gar nichts.
Egal. Ich habe meine Rechnung.

ProgrammierenSoftwareToolsVS 2013Martin Richter - Do 09 Apr 2015 20:15

In der letzten Zeit hatte ich immer mal wieder so einen komischen Effekt, dass ich VS-2013 gestartet habe und beim Öffnen einer Solution auf einmal nur noch die Eieruhr (Blue Circle of Death) zu sehen war. In der Anzeige stand meisten das irgend ein Projekt N vom M zu laden wäre. 🙁
Als mir das das erste mal passierte habe ich oft den Visual Studio Prozess brachial beendet, neu gestartet und dann ging es oft. Aber nicht immer. Wenn ich lang genug gewartet hatte wurde letzten Endes die Projekte immer geladen.

Weil mich das irgendwann nervte habe ich mal versucht Visual Studio selbst zu debuggen. Die Threads die aktiv waren, hatten immer was mit dem Team Foundation Server zu tun. Bald merkte ich, dass lokale Projekte nie betroffen waren sondern immer nur Solutions, die auch auf unserem zentralen TFS Server lagen.

Der nächste Schritt 💡 war dann beim nächsten Hänger mal die Firewall und den Netzwerkschutz abzuschalten. Wir verwenden hier seit Jahren Symantec Endpoint Protection (aktuell 12.1 RU5). Bingo !!! 🙂 Kaum, dass ich die Firewall abgeschaltet hatte lief, das Laden des Projektes sofort durch.

Entsprechend haben wir in den Firewall Einstellungen für Visual Studio jetzt eine Ausnahme Regel definiert und seit dem keine Probleme mehr. :mrgreen: