Exchange


ExchangeSoftwareMartin Richter - Mi 05 Dez 2007 19:42

Nun habe ich auch die Ursache für das Versagen der Onlinehilfe in der MMC des Exchange System Manager gefunden:
Es ist die IE7 Installation.

Nachzulesen hier: http://support.microsoft.com/kb/932513

Allerdings ist das nur die halbe Wahrheit. Die IE7 Installation ist mit Sicherheit nicht schuld, sondern nur der Auslöser. Wenn man sich diesen Fix ansieht, dann wird dort eine psapi.dll umbenannt. Mehr nicht!
Der Fix besteht also darin eine System-DLL, die lokal durch Exchange installiert wurde, außer Kraft zu setzen und die neueste DLL, die natürlich längst im Windows\System32 Verzeichnis liegt zu verwenden.

Bleibt die Frage: Warum hat das Exchange Team überhaupt eine lokale psapi.dll installiert und nicht die Datei verwendet, die mit dem OS von Windows 2003 ausgeliefert wird? Fakt ist, dass diese psapi.dll eine Uralt-Version für Windows 2000 mit Version 5.0 ist; Windows 2003 wurde mit einer Version 5.2 ausgeliefert.

ExchangeSoftwareMartin Richter - Di 04 Dez 2007 19:06

Auf einem meiner Windows 2003 R2 Server bekam ich permanent Abstürze sobald ich die Online-Hilfe im Exchange System-Manager aufrief.
Also dachte ich mir: „Schaust Du doch mal in die Online Hilfe“.

😯 Es springt mich die folgende Fehlermeldung an:

Hilfe und Support kann nicht geöffnet werden, da ein Systemdienst nicht ausgeführt wird.
Starten Sie „Hilfe und Support“, um dieses Problem zu beheben.

Eine dämlichere Fehlermeldung kann es wohl nicht geben! OK, Nach ein wenig googlen kam ich zu der Erkenntnis:
Der Dienst „Hilfe und Support“ fehlte bei mir in der Liste aller Dienste. Das mit dem Satz „Starten Sie „Hilfe und Support“, um dieses Problem zu beheben“ ein Dienst gemeint ist, kann hier wirklich nicht riechen.

Etwas mehr googeln ergab folgenden Fix:

  1. Wechseln in das Verzeichnis c:\windows\pchealth\helpctr
  2. Das gesamte Verzeichnis packagestore löschen
  3. Wechseln in das Verzeichnis c:\windows\pchealth\helpctr\binaries
    und dort den folgenden Befehl aus der Console starten:
    start /w helpsvc /svchost netsvcs /regserver /install

Sollte  helpsvc.exe nicht mehr vorhanden sein, oder der letzte Befehl fehlschlagen, muss man wohl diesen Teil neu installieren:

  1. Explorer starten und wechseln nach c:\windows\inf
  2. Rechtsklick auf die Datei pchealth.inf und Installieren auswählen
  3. Dienst wie oben unter 3. neu installieren.

Das Problem scheinen mehrere Leute sowohl mit XP, als auch Windows 2003 Server zu haben, nachdem Servicepacks installiert wurden. Wundert mich allerdings, weil in der letzten Zeit kein Servicepack installiert wurde.  Wahrscheinlich habe ich nur längere Zeit die Hilfe nicht verwendet 😉 und mirist es nicht aufgefallen.

Damit kann man zumindest mal wieder die Hilfe aufrufen. Warum aber mein Exchange System-Manager jegliche Online-Hilfe mit einem Absturz quittiert bleibt mir noch ein Rätsel…

ExchangeSoftwareMartin Richter - Mo 11 Jun 2007 19:19

Upps. Wie das? Keiner hat es bemerkt aber seit ein paar „Monaten“ scheint jeder bei uns volle Rechte auf jedes Postfach zu haben! 😮

Das ist nicht im Sinne des Erfinders, ganz und gar nicht!

Also suchen… aber wo. Mit der Hife von Frank Carius (MVP für Exchange und Herr über die Seite MSXFAQ.DE – Franks MSExchangeFAQ) bin ich dem übel auf die Spur gekommen.

Bestandsaufnahme:
Bei den Rechten auf dem Server in meiner Administrativen Gruppe sehe ich das Jeder die Rechte Send As und Receive As hat. Das soll aber nicht sein. Und noch schlimmer: Die Rechte werden geerbt…
Also klicke ich mich immer höher in der Hierarchie und hoffe bald den entsprechenden Eintrag zu finden. Aber da ist kein Eintrag. Und auf der Ebene der Organisationseinheit finde ich keine Eigenschafts Seite mit Sicherheit.

Oh Mann! Wer weiß denn schon, dass man diese Seite in den Eigenschaften auf der Ebene der Organisations Einheit nur sieht wenn man in der HKCU einen bestimmten Eintrag macht? Wohl nur ein Exchange Guru und das bin ich wirklich nicht…
Also unter HKEY_CURRENT_USER\Software\Microsoft\Exchange\EXAdmin den DWORD Eintrag ShowSecurityPage anlegt und dort 1 eingetragen.

Siehe da. Nun habe ich auch auf der Ebene der Organisation unter den Eigenschaften eine Sicherheits Seite! Und was finden wir hier? Die entsprechenden gesetzten Rechte, die irgendein </zensiert>*$%§5!%2%“!</zensiert> dort gesetzt hat. Also aus dem Recht für Jeder zwei Häkchen entfernt.

Nun sollte man nicht ungeduldig werden. Erst nach 30 Minuten hatte Active Directory die Änderung durch und der Exchange verhielt sich jetzt wieder „Privatsphäre schützend“. 🙂